[Sec-cert] [Mandriva] Schwachstelle in phpLDAPadmin bis einschliesslich Version 1.1.0.5 - MDVSA-2010:023

WiN Site Security Contacts win-sec-ssc at lists.dfn-cert.de
Fr Jan 22 14:23:04 CET 2010


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Liebe Kolleginnen und Kollegen,

soeben erreichte uns nachfolgendes Advisory von Mandriva Security. Wir
geben diese Informationen unveraendert an Sie weiter.

CVE-2009-4427 - Directory Traversal Schwachstelle im phpLDAPadmin
"cmd.php" Script

  Das phpLDAPadmin "cmd.php" Script ueberprueft den "cmd" Parameter nicht
  ausreichend auf enthaltene Shell Metazeichen (z.B. ".."). Ein
  entfernter Angreifer kann diese Schwachstelle dazu ausnutzen, auf
  beliebige Dateien des Webservers zuzugreifen und diese als PHP-Code
  auf dem Server auszufuehren.

Betroffen sind die folgenden Software Pakete und Plattformen:

  Paket phpldapadmin

  Mandriva Enterprise Server 5
  Mandriva Enterprise Server 5/X86_64

Vom Hersteller werden ueberarbeitete Pakete zur Verfuegung gestellt.

Hersteller Advisory:
  http://www.mandriva.com/security/advisories?name=MDVSA-2010:023


(c) der deutschen Zusammenfassung bei DFN-CERT Services GmbH; die
Verbreitung, auch auszugsweise, ist nur unter Hinweis auf den Urheber,
DFN-CERT Services GmbH, und nur zu nicht kommerziellen Zwecken
gestattet.

Mit freundlichen Gruessen,
        Detlev O. Matthies

- --

Detlev O. Matthies, M.Sc. (Incident Response Team)

DFN-CERT Services GmbH, https://www.dfn-cert.de, Phone  +49 40 808077-555
Sitz / Register: Hamburg, AG Hamburg, HRB 88805, Ust-IdNr.:  DE 232129737
Sachsenstrasse 5, 20097 Hamburg/Germany, CEO: Dr. Klaus-Peter Kossakowski

17. DFN Workshop    "Sicherheit in vernetzten Systemen"    09./10.02.2010
Informationen unter https://www.dfn-cert.de/veranstaltungen/workshop.html

- -----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2010:023
 http://www.mandriva.com/security/
 _______________________________________________________________________

 Package : phpldapadmin
 Date    : January 21, 2010
 Affected: Enterprise Server 5.0
 _______________________________________________________________________

 Problem Description:

 A vulnerability has been found and corrected in phpldapadmin:
 
 Directory traversal vulnerability in cmd.php in phpLDAPadmin 1.1.0.5
 allows remote attackers to include and execute arbitrary local files
 via a .. (dot dot) in the cmd parameter (CVE-2009-4427).
 
 The updated packages have been patched to correct thies issue.
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-4427
 _______________________________________________________________________

 Updated Packages:

 Mandriva Enterprise Server 5:
 04269a24be47cae01b6ad81ad46128a1  mes5/i586/phpldapadmin-1.1.0.7-1.1mdvmes5.noarch.rpm 
 322afd2a91fb2e6c4448d3cf86de4c49  mes5/SRPMS/phpldapadmin-1.1.0.7-1.1mdvmes5.src.rpm

 Mandriva Enterprise Server 5/X86_64:
 51a833830eeaf5e5e1e8ffacd2e2fd90  mes5/x86_64/phpldapadmin-1.1.0.7-1.1mdvmes5.noarch.rpm 
 322afd2a91fb2e6c4448d3cf86de4c49  mes5/SRPMS/phpldapadmin-1.1.0.7-1.1mdvmes5.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  <security*mandriva.com>
- -----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFLWEXemqjQ0CJFipgRAntXAJ94FOrq4yh3iaqozCLL8Rl3JjxoBwCfbVmt
6aGuXA3N/AEw2RgKgZGmLyU=
=BUgG
- -----END PGP SIGNATURE-----
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFLWaa4WmhIvjFb90URAgC9AJ0RD0tnTcF7UsL/CqBOpfVVHze13gCeKb0o
hl+Ze1DksvhtWR0yvsj9fMk=
=OFQD
-----END PGP SIGNATURE-----



Mehr Informationen über die Mailingliste Sec-cert