[Sec-cert] DFN-CERT-2013-1347 Mehrere Schwachstellen in PHP5 [Linux][SuSE]

portal at dfn-cert.de portal at dfn-cert.de
Do Jul 25 14:54:42 CEST 2013


Liebe Kolleginnen und Kollegen,

bitte beachten Sie die folgende Sicherheitsmeldung.

Betroffene Software:

  Paket php5

Betroffene Plattformen:

  openSUSE 12.3
  openSUSE 12.2
  openSUSE 11.4


Mehrere Schwachstellen in PHP5 ermöglichen einem entfernten Angreifer
schlimmstenfalls beliebige Befehle zur Ausführung zu bringen.


Software Upgrade:

  Der Hersteller stellt Updates zur Behebung der Schwachstelle bereit.

  <http://download.novell.com/index.jsp>


CVE-2013-4635: Integer Overflow Schwachstelle in PHP5

  In PHP5 enthält die Funktion SdnToJewish() in der Datei 'jewish.c' der
  Calendar-Komponente einen Integer Overflow. Dies ermöglicht einem entfernten
  Angreifer durch das Übergeben eines übergroßen Argumentes an die Funktion
  SdnToJewish() einen Denial-of-Service-Angriff durchzuführen.


CVE-2013-4113: Buffer-Overflow-Schwachstelle in PHP

  PHP enthält in der Funktion xml_parse_into_struct() beim Parsen von
  verschachtelten XML-Dokumenten einen Buffer Overflow. Dieser ermöglicht
  einem entfernten Angreifer durch das Bereitstellen von präparierten
  XML-Daten beliebige Befehle zur Ausführung zu bringen.


CVE-2013-1635: Schwachstelle in PHP

  Falls eine PHP-Anwendung nicht vertrauenswürdige SOAP-Objekte von entfernten
  Klienten akzeptiert, ist es einem entfernten Angreifer möglich beliebige für
  den Webserver lesbare Systemdateien zu lesen.


CVE-2013-1643: Schwachstelle in PHP

  Die Funktion 'soap.wsdl_cache_dir' in PHP berücksichtigt die
  'open_basedir'-Beschränkungen nicht. Dies ermöglicht einem entfernten
  Angreifer unrechtmäßigen Zugriff auf Dateien zu erhalten.


Referenzen:

Dieses Advisory finden Sie auch im DFN-CERT Portal unter:
  <https://portal.cert.dfn.de/adv/DFN-CERT-2013-1347/>

Das Hersteller Advisory:
  <http://lists.opensuse.org/opensuse-updates/>

Schwachstelle CVE-2013-1635:
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-1635>

Schwachstelle CVE-2013-1643:
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-1643>

Schwachstelle CVE-2013-4113:
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4113>

Schwachstelle CVE-2013-4635:
  <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4635>


(c) DFN-CERT Services GmbH
Die nicht kommerzielle Weiterverbreitung ist mit Hinweis auf den
Copyrightinhaber erlaubt.
-------------- nächster Teil --------------
Ein Dateianhang mit Binärdaten wurde abgetrennt...
Dateiname   : smime.p7s
Dateityp    : application/pkcs7-signature
Dateigröße  : 4335 bytes
Beschreibung: nicht verfügbar
URL         : <https://listserv.uni-hohenheim.de/pipermail/sec-cert/attachments/20130725/4225dd2d/attachment.p7s>


Mehr Informationen über die Mailingliste Sec-cert